Welcome, Guest. Please login or register.
Apr 19, 14, 07:57PM
Home Help Search Login Register
News:

+  Do It Yourself Home Security Alarm Forum
|-+  Technical Support
| |-+  DSC Technical Questions
| | |-+  Alexor won't connect to DLS-IV
« previous next »
Pages: [1] Print
Author Topic: Alexor won't connect to DLS-IV  (Read 2727 times)
greenbird
Newbie
*

Karma: +0/-0
Posts: 10


« on: Feb 06, 11, 09:00PM »

Hey guys,

I'm trying to connect an Alexor PC9155CP-01 with v1.10 firmware, but no matter what I try (Global Upload, Global Download, specific tags, etc.), I can't get it to connect to DLS-IV. Punching in [499] <installer code> [499] doesn't make a difference either.  Cry

I've got the cable properly wired up as far as I can tell:

PC-Link      DB9
    [1] <--> [3]
    [2] <--> [5] ground
    [3] <--> [5] ground
    [4] <--> [2]
["Red"] <--> no connection
        /--> [4]
  jumper
        \--> [6]

At first, I thought my USB converter was the problem, but I'm now running it on another PC with a built-in serial-port and I'm having the exact same issue.

For software, I am running the latest NA version of DLS-IV, 1.3.1009.27001, downloaded through the automatic updater.

I confirmed that the serial hook-up is passing data because if I put the PC-Link connector into GPRS/Ethernet mode ([382][5]), I can see some data being sent by the Alexor every second. Nothing shows up if I reverse the serial cable.

Anybody know what I'm doing wrong?  Huh?

Thanks,

Victor
Logged
Old EW Tech
Tech Advisor/Moderator
*

Karma: +210/-0
Posts: 8988

40 yrs. in system design


« Reply #1 on: Feb 07, 11, 01:24PM »

Just from memory, your diagram doesn't look right.

The forum's search feature should bring one up for you to compare (try "PC-Link pin out", "PC-Link diagram", etc for search terms and restrict search to DSC Forum). 
Logged

If you don't have time to do it right the first time ...how are you ever going to find time to do it over?
greenbird
Newbie
*

Karma: +0/-0
Posts: 10


« Reply #2 on: Feb 07, 11, 01:46PM »

Thanks for the hint, Old EW.

Here's the most relevant post I found in the forums:

http://www.diyalarmforum.com/board/index.php?topic=15.0

The two wirings look the same to me, except for the question of pin outs on the Alexor's PC-Link.

One pin is very clearly labeled as "Red", which I call pin 5:

| [1]
| [2]
| [3]
| [4]
  [5] "Red"

The | indicates the white bar on the PCB's silk screening to show where the DSC PC-Link cable should go / orientation.

So the question (especailly for Alexor users) is: What are the pin assignments for pins 1-5? I believe 2 and 3 are grounds and 5 ("Red") is a +16.5V power source.

Has anybody been able to successfully connect the Alexor PC9155 to DLS-IV? If so, can you provide a walk-through on how to get it wired and connected properly?

Thanks!

Victor
Logged
Old EW Tech
Tech Advisor/Moderator
*

Karma: +210/-0
Posts: 8988

40 yrs. in system design


« Reply #3 on: Feb 07, 11, 02:34PM »

Quote
Has anybody been able to successfully connect the Alexor PC9155 to DLS-IV?

Of course.
 
The standard 4-pin PC-Link cable will work on the Alexor (using the top 4 pins).

If you're having difficulty connecting and are unsure of the cable, why not buy the PC-Link cable and eliminate a variable?
Logged

If you don't have time to do it right the first time ...how are you ever going to find time to do it over?
greenbird
Newbie
*

Karma: +0/-0
Posts: 10


« Reply #4 on: Feb 07, 11, 03:38PM »

Good point. I'll buck up and spend the extra few bucks. Normally I'm pretty good at wiring things up, but in this case, who knows. I'll report back if the cable from DSC solves my problem.

Thanks for the sound advice, Old EW.

Cheers,

Victor
Logged
Old EW Tech
Tech Advisor/Moderator
*

Karma: +210/-0
Posts: 8988

40 yrs. in system design


« Reply #5 on: Feb 07, 11, 03:53PM »

That's the spirit.  Smiley

If you have any problem with the "store-bought", we'll do our best to get you up and running.
Logged

If you don't have time to do it right the first time ...how are you ever going to find time to do it over?
greenbird
Newbie
*

Karma: +0/-0
Posts: 10


« Reply #6 on: Feb 12, 11, 09:26PM »

Found the solution to my problem... and it may surprise you...

THE SERIAL PORT! For whatever reason, a REAL DB9 RS-232 serial port on an Intel motherboard would not connect to the PC9155, but using a Keyspan USA-19HS USB-serial converter worked.  Shocked

This confirms that the wiring of my "home-brewed" cable is fine and no, the "Red" pin is not used when connecting via DLS IV.

Thanks again to Old EW Tech for the pointers.

Cheers,

Victor
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length